Azure CmdLets error: …no endpoint listening…

This had now happened too many times and I can never remember, so here’s a mental note –

When using PowerShell to create a VM on Azure (I suspect this would apply in other circumstances too), I occasionally bump into this error

New-AzureVM : There was no endpoint listening at https://management.core.windows.net/<subscription id>/services/storageservices/<storage account> that could accept the message. This is often caused by an incorrect address or SOAP action.

The important pieces of information in this message is the first GUID I’ve replaced here with <subscription id> and the second which I’ve replaced with <storage account> – this determines which storage endpoint will be used when creating the VM and are picked up according to the parameters used for the Set-AzureSubscription I’ve blogged about previously

The error above is displayed typically when one of these parameters are not set or set incorrectly. if you haven’t used Set-AzureSubscription the cmdlet will not know where to look for the endpoint.

Equally, I’ve managed in one or two occasions to mistakenly set an inompatible subscription id and storage account , that is – set subscription id ‘A’ with a storage account that belongs to subscription ‘B’ – this also, of course, cannot be resolved and will raise the same error.

About Yossi Dahan
I work as a cloud solutions architect in the Azure team at Microsoft UK. I spend my days working with customers helping be successful in the cloud with Microsoft Azure.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: